summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEugene Konev <ejka@imfi.kspu.ru>2007-05-28 21:53:02 -0400
committerDavid Nusinow <dnusinow@debian.org>2007-05-28 21:53:02 -0400
commit857ddbb660a21cad1c16f4fb2dc8a904d6655304 (patch)
tree35dd1bdcf007ab38dbfeb6d4624c0315b16efb29 /configure.ac
parent78d01d1008973899d931ef44b47d5f0b5f220b0d (diff)
Allow configurable serverconfigdir for security policy location
Allow the location of the SERVERCONFIGdir variable to be defined at compile-time. This allows us to specify where the security policy will be located (Debian uses this to put it in /etc). The default is to the previous location.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37199cf26..7ff712f63 100644
--- a/configure.ac
+++ b/configure.ac
@@ -465,6 +465,9 @@ AC_ARG_WITH(xkb-output, AS_HELP_STRING([--with-xkb-output=PATH], [Path to
AC_ARG_WITH(rgb-path, AS_HELP_STRING([--with-rgb-path=PATH], [Path to RGB database (default: ${datadir}/X11/rgb)]),
[ RGBPATH="$withval" ],
[ RGBPATH="${datadir}/X11/rgb" ])
+AC_ARG_WITH(serverconfig-path, AS_HELP_STRING([--with-serverconfig-path=PATH], [Path to server config (default: ${libdir}/xserver)]),
+ [ SERVERCONFIG="$withval" ],
+ [ SERVERCONFIG="${libdir}/xserver" ])
APPLE_APPLICATIONS_DIR="${bindir}/Applications"
AC_ARG_WITH(apple-applications-dir,AS_HELP_STRING([--with-apple-applications-dir=PATH], [Path to the Applications directory (default: ${bindir}/Applications)]),
[ APPLE_APPLICATIONS_DIR="${withval}" ].
@@ -938,6 +941,7 @@ VENDOR_MAN_VERSION="Version ${VENDOR_VERSION_STRING}"
AC_DEFINE_DIR(COMPILEDDEFAULTFONTPATH, FONTPATH, [Default font path])
AC_DEFINE_DIR(RGB_DB, RGBPATH, [Default RGB path])
+AC_DEFINE_DIR(SERVERCONFIGdir, SERVERCONFIG, [Server config path])
AC_DEFINE_DIR(BASE_FONT_PATH, FONTDIR, [Default base font path])
AC_DEFINE_DIR(DRI_DRIVER_PATH, DRI_DRIVER_PATH, [Default DRI driver path])
AC_DEFINE_UNQUOTED(XVENDORNAME, ["$VENDOR_STRING"], [Vendor name])