summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-10-16 17:27:19 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-10-16 10:47:22 -0400
commitfb39d8d23cc445ecb1306484490da34589f0e3e9 (patch)
tree05a4d04ede128fbfad6e1ae2df5985cd1018eed1 /configure.ac
parentde7fe62a540f01d0b3a3af7727b81718aad2c94a (diff)
toytoolkit: make all EGL code dependant on cairo-egl
configure.ac: The toytoolkit clients used to get libEGL linked to them even if there was no cairo-egl. This is useless, and actually harmful on platforms, where libEGL absolutely requires one of the GL ES libraries to be linked in, too. Look for EGL-related packages only for cairo-egl with toytoolkit. window.c: protect all GL header includes with HAVE_CAIRO_EGL, since that is the only case we can support EGL, GL, or GLESv2 at all. In the case we do not have cairo-egl, add enough definitions to let us build the stubs for EGL-related functions. Remove some #ifdefs that were inside of the same #ifdef already. These changes allow to build sorfware rendering toytoolkit clients without any bits of EGL libs or headers. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c2cd7daf..8b8e9a2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,7 +164,7 @@ AM_CONDITIONAL(BUILD_CLIENTS, test x$enable_clients = xyes)
if test x$enable_clients = xyes; then
AC_DEFINE([BUILD_CLIENTS], [1], [Build the Wayland clients])
- PKG_CHECK_MODULES(CLIENT, [wayland-client wayland-egl egl >= 7.10 cairo >= 1.10.0 xkbcommon wayland-cursor])
+ PKG_CHECK_MODULES(CLIENT, [wayland-client cairo >= 1.10.0 xkbcommon wayland-cursor])
PKG_CHECK_MODULES(WESTON_INFO, [wayland-client])
CLIENT_CFLAGS="$CLIENT_CFLAGS $IMAGE_CFLAGS"
@@ -172,7 +172,7 @@ if test x$enable_clients = xyes; then
PKG_CHECK_MODULES(POPPLER, [poppler-glib glib-2.0 gobject-2.0 gio-2.0 ],
[have_poppler=yes], [have_poppler=no])
- PKG_CHECK_MODULES(CAIRO_EGL, [cairo-egl >= 1.11.3 $cairo_modules],
+ PKG_CHECK_MODULES(CAIRO_EGL, [wayland-egl egl >= 7.10 cairo-egl >= 1.11.3 $cairo_modules],
[have_cairo_egl=yes], [have_cairo_egl=no])
AS_IF([test "x$have_cairo_egl" = "xyes"],
[AC_DEFINE([HAVE_CAIRO_EGL], [1], [Have cairo-egl])],