summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-11-07 12:25:12 +0200
committerKristian Høgsberg <krh@bitplanet.net>2012-11-08 16:56:25 -0500
commita51e6fa322a24979ec04d7cdec08d3bdcf279b12 (patch)
tree74997da2dd640471778c8b48037a51f1a9e559e4 /configure.ac
parentf97f811cf3a622f57b7ad098a33c844b9deae050 (diff)
build: make default backend configurable
Instead of hardcoding drm-backend.so as the default if environment presents neither Wayland nor X11, have a ./configure option to change it. It still defaults to drm-backend.so, if not given. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7d403cf1..ecaea63f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,9 @@ AC_PROG_SED
LT_PREREQ([2.2])
LT_INIT([disable-static])
+AC_ARG_VAR([WESTON_NATIVE_BACKEND],
+ [Set the native backend to use, if Weston is not running under Wayland nor X11. @<:@default=drm-backend.so@:>@])
+
PKG_PROG_PKG_CONFIG()
AC_CHECK_FUNC([dlopen], [],
@@ -255,6 +258,13 @@ fi
AC_SUBST(GCC_CFLAGS)
AC_SUBST(GCC_CXXFLAGS)
+if test "x$WESTON_NATIVE_BACKEND" = "x"; then
+ WESTON_NATIVE_BACKEND="drm-backend.so"
+fi
+AC_MSG_NOTICE([Weston's native backend: $WESTON_NATIVE_BACKEND])
+AC_DEFINE_UNQUOTED([WESTON_NATIVE_BACKEND], ["$WESTON_NATIVE_BACKEND"],
+ [The default backend to load, if not wayland nor x11.])
+
WAYLAND_SCANNER_RULES(['$(top_srcdir)/protocol'])
AC_CONFIG_FILES([Makefile