summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 767919e..9fdf040 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,12 +6,16 @@ TESTS = \
connection-test \
event-loop-test \
client-test \
- os-wrappers-test
+ os-wrappers-test \
+ fixed-test
check_PROGRAMS = \
$(TESTS) \
exec-fd-leak-checker
+noinst_PROGRAMS = \
+ fixed-benchmark
+
test_runner_src = test-runner.c test-runner.h test-helpers.c
sanity_test_SOURCES = sanity-test.c $(test_runner_src)
@@ -21,6 +25,9 @@ list_test_SOURCES = list-test.c $(test_runner_src)
connection_test_SOURCES = connection-test.c $(test_runner_src)
event_loop_test_SOURCES = event-loop-test.c $(test_runner_src)
client_test_SOURCES = client-test.c $(test_runner_src)
+fixed_test_SOURCES = fixed-test.c $(test_runner_src)
+
+fixed_benchmark_SOURCES = fixed-benchmark.c
os_wrappers_test_SOURCES = \
os-wrappers-test.c \