summaryrefslogtreecommitdiff
path: root/vte.spec
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2002-10-10 16:57:30 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2002-10-10 16:57:30 +0000
commit272bef21f4676bd586bbd9484890d6d2aa47fce7 (patch)
tree114959c018b65ad6587d485ff43c8f116f4157c1 /vte.spec
parent9705656987dfb648692f14556143fa999a28e5bb (diff)
allow specifying the scrollback buffer size. if we don't have <wchar.h>,
* src/vteapp.c, python/vte-demo.py: allow specifying the scrollback buffer size. * src/vte.c: if we don't have <wchar.h>, typedef wchar_t as a gunichar, not a long. * src/buffer.c, src/buffer.h: add. * src/interpret.c, src/vte.c: use _vte_buffer structures instead of char arrays with separate lengths. Use a scratch buffer for holding the results of conversions. * src/vte.c: separate the pango and pangox drawing paths so that they're easier to tweak and compare to each other. * src/vte.c: ditch the smooth scrolling change, which won't work right anyway (expose events don't get processed until after we finish processing a chunk of data unless we explicitly request it, so using a bbox is both simpler and faster). Use a mask when creating the cursor we use for hiding the cursor. * vte.spec, gnome-pty-helper/Makefile.am: install gnome-pty-helper into the libexecdir, not pkglibdir (#95085). * src/vte.c: obey smooth/jump scrolling options, default is jump scroll. * src/vte.c (vte_font_match): Fix over-aggressive Xft => Fc conversion - need to call XftDefaultSubstitute to pick up Xft X resources, not FcDefaultSubstitute. From otaylor.
Diffstat (limited to 'vte.spec')
-rw-r--r--vte.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/vte.spec b/vte.spec
index 15b5593..8b41706 100644
--- a/vte.spec
+++ b/vte.spec
@@ -28,7 +28,7 @@ package contains the files needed for building applications using VTE.
if [ -x %{_bindir}/python2.2 ]; then
PYTHON=%{_bindir}/python2.2; export PYTHON
fi
-%configure --enable-shared --enable-static
+%configure --enable-shared --enable-static --libexecdir=%{_libdir}/%{name}
make
%clean