summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2003-04-29 03:12:32 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2003-04-29 03:12:32 +0000
commit391a3afbbbb5d40c624708e6697626199af8f358 (patch)
tree22845356af3ba1cbea69168ab6581af91d798dbc /src/Makefile.am
parent627ac390f1a7f28751aa641bf2e96ba7781aef24 (diff)
rework to simplify the logic of how many cells to invalidate when we have
* src/vte.c(vte_invalidate_cursor_once): rework to simplify the logic of how many cells to invalidate when we have a preedit string. * src/vte.c(vte_terminal_paint): draw the preedit string correctly for cases more complicated than the default IM (seems to fix #111767). * src/vterdb.c(_vte_rdb_get): use g_strncpy() and the property length to avoid going past the end of the possibly-not-nul-terminated string. * src/Makefile.am: build a standalone vterdb binary.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f1f6eeb..f76d46b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,7 @@
bin_PROGRAMS = vte
pkginclude_HEADERS = pty.h reaper.h vte.h vteaccess.h
lib_LTLIBRARIES = libvte.la
-pkglib_PROGRAMS = interpret utf8echo nativeecho utf8mode iso8859mode slowcat
+pkglib_PROGRAMS = interpret utf8echo nativeecho utf8mode iso8859mode slowcat vterdb
pkglib_SCRIPTS = decset osc window
noinst_PROGRAMS = buffer dumpkeys iso2022 pty reaper reflect-text-view reflect-vte $(REFLECT_ZVT) ring mev ssfe table termcap trie xticker
EXTRA_DIST = \
@@ -229,6 +229,10 @@ reaper_SOURCES = \
reaper.h
reaper_LDADD = @LDFLAGS@ @LIBS@ @GOBJECT_LIBS@
+vterdb_CFLAGS = @CFLAGS@ @GTK_CFLAGS@ -DVTERDB_MAIN
+vterdb_SOURCES = vterdb.c
+vterdb_LDADD = @LDFLAGS@ @LIBS@ @GTK_LIBS@
+
buffer_CFLAGS = @CFLAGS@ @GLIB_CFLAGS@ -DBUFFER_MAIN
buffer_SOURCES = buffer.c
buffer_LDADD = @LDFLAGS@ @GLIB_LIBS@