summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@src.gnome.org>2002-05-01 15:40:13 +0000
committerNalin Dahyabhai <nalin@src.gnome.org>2002-05-01 15:40:13 +0000
commit92d904d5dd39221b2ab942c2cc59056a50b357cc (patch)
treecb3b8cc5dfd5b88d6d805597010f94a7614ada6f /configure.in
parent4461f119849629f1ecca1003e78113d8cc3aa8fc (diff)
Try @pkgdatadir@/termcap/$TERM when reading termcap files. This fixes thevte_0_3_2
* src/vte.c: Try @pkgdatadir@/termcap/$TERM when reading termcap files. This fixes the app on systems with no /etc/termcap, and also speeds up loads and reduces memory consumption for xterm-color at the expense of making on-the-fly emulation changes impossible. Don't xor reverse with itself when drawing characters (this broke when snapshotting was added). * termcaps/Makefile.am, termcaps/xterm-color: include a default termcap for xterm-color. * src/termcap.c src/termcap.h: make _find_boolean return a gboolean instead of an int.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b2944f5..0af3dff 100644
--- a/configure.in
+++ b/configure.in
@@ -51,5 +51,13 @@ fi
if test x$VTE_DEBUG = x1 ; then
AC_DEFINE(VTE_DEBUG,,[Enable debugging of unrecognized sequences.])
fi
+
+mydatadir=`eval echo $datadir`
+if test x$prefix = xNONE ; then
+ mydatadir=`echo $mydatadir | sed s,NONE,$ac_default_prefix,g`
+fi
+AC_DEFINE_UNQUOTED(DATADIR,"$mydatadir",
+ [The location where arch-independent package-specific data can be found.])
+
AM_CONFIG_HEADER(config.h)
-AC_OUTPUT([Makefile src/Makefile vte.pc])
+AC_OUTPUT([Makefile src/Makefile termcaps/Makefile vte.pc])