summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorBrice Goglin <bgoglin@debian.org>2009-07-13 23:31:03 +0200
committerBrice Goglin <bgoglin@debian.org>2009-07-13 23:48:17 +0200
commitc0c0610b6ad2ff99284f61dfe42520b7d6a5dc69 (patch)
tree6ef59aa93f746a5642f99e8122f6376ed9cf6139 /ChangeLog
parentcf1f5862111010532a08a7f28c02af3f0fbfe649 (diff)
New upstream release
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog333
1 files changed, 333 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index ccf2e0fea..c0b8045fc 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,336 @@
+commit 606f6dba16d42e3546a82a386d5a01087467b511
+Author: Adam Jackson <ajax@redhat.com>
+Date: Tue Apr 14 10:54:25 2009 -0400
+
+ xdmcp: Don't crash on X -query with more than 255 IP addresses. (#20675)
+
+ You could be more clever than this, but the wire protocol says this
+ really is an array of not more than 255 ARRAY8, so it's not just a
+ matter of changing the types.
+
+ (cherry picked from commit 0eb19f9437b7d8c19592e49eedb028771d300d80)
+
+commit 396d3a7762abd0dd84042833b75f2ebf9d100bb0
+Author: Alan Coopersmith <alan.coopersmith@sun.com>
+Date: Wed Jul 8 11:26:46 2009 -0700
+
+ Fix build of drivers with 1.6.2 when not using --install-libxf86config
+
+ c859b736d1d23c5dc2f53958b1e76660e6d45018 removed duplicate entries for
+ these from the Makefile, but removed a different set than was done in
+ master branch, causing xf86Parser.h to not be installed, which in turn
+ breaks the build of drivers like -ati, -intel & -nv that use xf86Modes.h,
+ which includes xf86Parser.h
+
+ Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 6f1aff5a2b45bc2985081abc240a8fed37170386
+Author: Keith Packard <keithp@keithp.com>
+Date: Mon Jul 6 14:08:31 2009 -0700
+
+ Bump to version 1.6.2
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 499f9f62e408510ed4efb6f2321a3f851f535567
+Author: Keith Packard <keithp@keithp.com>
+Date: Wed Jul 1 14:01:57 2009 -0700
+
+ dri2: Preserve compatibility with 1.6 DRI2 API/ABI
+
+ The old DRI2 buffer allocation API wasn't great, but there's no reason to
+ make the server stop working with those drivers. This patch has the
+ X server adapting to the API provided by the driver, using the new API where
+ available and falling back to the old API as necessary. A warning will be
+ placed in the log file when the old API is in use.
+ (cherry picked from commit 2e2c5b216cc1c7a9bc26bd2c68226aaed5fc52ca)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit c859b736d1d23c5dc2f53958b1e76660e6d45018
+Author: Arkadiusz Miskiewicz <arekm@maven.pl>
+Date: Fri Jul 3 11:03:32 2009 +0200
+
+ xfree86: remove duplicate header entries in Makefile.am
+
+ fixes https://bugs.freedesktop.org/show_bug.cgi?id=22547
+
+ This bug was fixed in a big clean-up commit in master, which cannot be
+ backported (see commit b1dac41fb3853ca8182048ea57b88b6e84ecceb3)
+
+ Signed-off-by: Rémi Cardona <remi@gentoo.org>
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 6f82ca0f8bfc074474407cb5ffe782c3c128f838
+Author: Alan Hourihane <alanh@vmware.com>
+Date: Mon Feb 16 11:39:34 2009 +0000
+
+ dri2: support glXWaitGL & glXWaitX by copying fake front to front and
+ vice-versa.
+ (cherry picked from commit 2a8b8077d8f6001eb57deba60e1009fc99c28668)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit d478bc948838d11b3abcf6d2cdd3a00dccb344c4
+Author: Eric Anholt <eric@anholt.net>
+Date: Tue Feb 17 09:59:17 2009 -0800
+
+ xinerama: Put the proto version in the code instead using proto headers.
+
+ Proto headers updating resulting in the server advertising new versions is
+ broken. This should be applied to every extension.
+
+ This fixes the build against slightly-older xineramaproto.
+ (cherry picked from commit b349a764e98f0d8f221190157ffa0904b91beca5)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit a7a93c12f91e0de72868f17a555215f1795d9e2f
+Author: Keith Packard <keithp@keithp.com>
+Date: Mon Jun 29 23:18:55 2009 -0700
+
+ Build against DRI_TEX_BUFFER_VERSION 1
+
+ setTexBuffer2 isn't present in this version of the structure, so don't try
+ to call it.
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 5b49aff4f8b5e4d15bc883f74509d93324f09f5f
+Author: Keith Packard <keithp@keithp.com>
+Date: Mon Jun 29 14:40:46 2009 -0700
+
+ Bump version to 1.6.1.902
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit e97cabce4abdaf6b83d1a442f7972d4c45979b33
+Author: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Wed Mar 25 12:55:42 2009 +1000
+
+ xfree86: fix SWCursor check in xf86CursorSetCursor.
+
+ Wrong check for inputInfo.pointer resulted in a SW cursor being rendered when
+ the pointer left the screen (in a Xinerama setup).
+ We must call the sprite rendering function if
+ - SW cursors are enabled, or
+ - The current device is not the VCP and not attached to the VCP.
+
+ Backported from commit 66089e9129a821cfb1983d3d35f41b975a52de5e for
+ server-1.6-branch by Peter Hutterer
+
+ Reported-by: Gordon Yuan <GordonYuan@viatech.com.cn>
+ Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 17c5b2caf01deec1d1be9fc2ac68a3d636e64c44
+Author: Julien Cristau <jcristau@debian.org>
+Date: Mon May 18 19:01:46 2009 +0200
+
+ Change default for ExaOptimizeMigration to false
+
+ Quoting Michel Dänzer in <1234862541.4823.541.camel@thor>:
+
+ Unfortunately, there are still bugs left in EXA which prevent it from
+ working 100% correctly with the option enabled, see
+
+ http://bugs.freedesktop.org/show_bug.cgi?id=16416
+
+ http://bugs.freedesktop.org/show_bug.cgi?id=19940
+
+ So disable it for now to avoid corruption.
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 8d65439d5c950ea01ec8e1e4dd989aff0fb4c3f0
+Author: Keith Packard <keithp@keithp.com>
+Date: Thu May 28 14:43:27 2009 -0700
+
+ Make RANDR 'set' timestamps follow client specified time. Bug 21987.
+
+ The lastSetTime value which indicates when the configuration within the
+ server was last changed was not getting set in the appropriate RandR
+ requests.
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+ (cherry picked from commit 69a9545d1f8110841538410818df19fd960412c5)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit d98f2792d2f523d7397eac70cc021761e9561219
+Author: Federico Mena Quintero <federico@novell.com>
+Date: Tue Jun 9 13:28:28 2009 -0700
+
+ dix/randr: Add missing fields to SRR*NotifyEvent()
+
+ Also, remove redundant field swaps and make others match the order in which
+ they are declared in the xRR*NotifyEvent structs.
+
+ Signed-off-by: Federico Mena Quintero <federico@novell.com>
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+ (cherry picked from commit e244a5991e2cc55f5aa2f6e5255f1dabf56f0235)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit f697b6c582095aa1eec3244fa05835922249425b
+Author: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Mon May 11 12:53:56 2009 +1000
+
+ kdrive: set Activate/Deactivate grab for input devices (#21591)
+
+ X.Org Bug 21591 <http://bugs.freedesktop.org/show_bug.cgi?id=21591>
+ (cherry picked from commit b1b5ec45c1cb650ccb8c659218f9481379c777d9)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit c91accd173b5f17af771bd9f4e60b5860af15718
+Author: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Mon May 11 12:51:40 2009 +1000
+
+ dix: ensure Activate/DeactivateGrab has a valid value.
+
+ Xephyr doesn't manually set Activate/DeactivateGrab for new devices,
+ resulting in a NULL-pointer dereference later when a grab is activated.
+ Avoid the segfault by ensuring that the pointer is always valid.
+
+ Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+ (cherry picked from commit 6f9e22049862ee9ac7f604411d005d8bb1b2dd1c)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit bd94c7c986aed4496cd4e8141bb30c3e4412f1f4
+Author: Alan Coopersmith <alan.coopersmith@sun.com>
+Date: Tue May 12 16:11:01 2009 -0700
+
+ Resync COPYING file with notices in code base as of xorg-server-1.6.1
+
+ Remove notices for code no longer in tree (Xprint, Xgl, kdrive, cfb, etc.)
+ Add/update notices for new/changed code in tree
+
+ Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
+ (cherry picked from commit b746a00cffca5c553b607a8e9c1074294a23b443)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 597747c6551cd67487069415297e5eb441038321
+Author: Jeremy Huddleston <jeremyhu@freedesktop.org>
+Date: Sat May 9 11:42:17 2009 -0700
+
+ Fix a couple off-by-one array boundary checks.
+
+ Error: Write outside array bounds at Xext/geext.c:406
+ in function 'GEWindowSetMask' [Symbolic analysis]
+ In array dereference of cli->nextSib[extension] with index 'extension'
+ Array size is 128 elements (of 4 bytes each), index <= 128
+
+ Error: Buffer overflow at dix/events.c:592
+ in function 'SetMaskForEvent' [Symbolic analysis]
+ In array dereference of filters[deviceid] with index 'deviceid'
+ Array size is 20 elements (of 512 bytes each), index >= 0 and index <= 20
+
+ Error: Read buffer overflow at hw/xfree86/loader/loader.c:226
+ in function 'LoaderOpen' [Symbolic analysis]
+ In array dereference of refCount[new_handle] with index 'new_handle'
+ Array size is 256 elements (of 4 bytes each), index >= 1 and index <= 256
+
+ These bugs were found using the Parfait source code analysis tool.
+ For more information see http://research.sun.com/projects/parfait
+
+ Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
+ Signed-off-by: Adam Jackson <ajax@redhat.com>
+ Acked-by: Peter Hutterer <peter.hutterer@who-t.net>
+ (cherry picked from commit b680bda34da130ce408783f04214771471e41e8d)
+ (cherry picked from commit 04c9e80f083659e63cffec8969fb3a0cfc551a97)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 10c06ddeefccc195e70adfed664e9488eeb53804
+Author: Peter Hutterer <peter.hutterer@who-t.net>
+Date: Thu Apr 9 15:40:24 2009 +1000
+
+ xfree86: restore default off for DontZap
+
+ Zapping is triggered by xkb these days, so note in the man page that it's the
+ Terminate_Server action. Since it's XKB, personal preferences towards or
+ against zapping should be achieved through xkb rulesets.
+ If Terminate_Server is not in the xkb actions, then we can't zap anyway and we
+ don't need a default of DontZap "on".
+
+ This patch restores the old meaning of DontZap - disallow zapping altogether,
+ regardless of XKB's current keymap.
+ Ideally, this patch should be accompanied by b0f64bdab00db652e in
+ xkeyboard-config.
+
+ Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+ (cherry picked from commit 737b49199a05299486064e6e762cf2a2f6f95be6)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 966349f8e068fa120470549b0db9a8fcf88aca5b
+Author: Michel Dänzer <daenzer@vmware.com>
+Date: Fri May 15 15:48:37 2009 +0200
+
+ EXA: Always damage glyph cache pixmap manually after uploading a glyph.
+
+ Signed-off-by: Michel Dänzer <daenzer@vmware.com>
+ (cherry picked from commit 7c8327f0a75087a85864256a9cea80dd4b86def5)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit cc5e4b632aa99623ff577776039287c5950d921d
+Author: Michel Dänzer <daenzer@vmware.com>
+Date: Fri May 15 15:48:37 2009 +0200
+
+ EXA: Take GC client clip type into account for migration.
+
+ Fixes http://bugs.freedesktop.org/show_bug.cgi?id=18950 .
+
+ Signed-off-by: Michel Dänzer <daenzer@vmware.com>
+ (cherry picked from commit 850675d4de4373e5df95507dbf2cd9affaaf54bc)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit bbe0be1e459b0d5810a0e7b916cc890c440a4e21
+Author: Tomas Janousek <tomi@nomi.cz>
+Date: Wed May 20 15:03:01 2009 +0200
+
+ Bug #6428, #16458, #21464: Fix crash due to uninitialized VModMap fields.
+
+ In ProcXkbGetKbdByName, mrep.firstVModMapKey, .nVModMapKeys and
+ .totalVModMapKeys were not initialized, contained random values and caused
+ accesses to unallocated and later modified memory, causing
+ XkbSizeVirtualModMap and XkbWriteVirtualModMap to see different number of
+ nonzero values, resulting in writes past the end of an array in XkbSendMap.
+
+ This patch initializes those values sensibly and reverts commits 5c0a2088 and
+ 6dd4fc46, which have been plain non-sense.
+
+ Signed-off-by: Tomas Janousek <tomi@nomi.cz>
+ Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
+ (cherry picked from commit 525aa17f804d37d1cfcbbf6b8e6cddb45e999b20)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 6056d429e7dcc37fe706dd7bc8d3429fdb635e14
+Author: Kristian Høgsberg <krh@redhat.com>
+Date: Wed Apr 1 17:42:33 2009 -0400
+
+ Support setTexBuffer2 in AIGLX.
+
+ Fixes broken GLX_tfp, specifically, lets compositors ignore un-defined
+ alpha channel for pixmaps.
+ (cherry picked from commit 91b697efdefba125348dbcaf584ee51a7f8c9bf6)
+
+ Signed-off-by: Keith Packard <keithp@keithp.com>
+
+commit 7cae08d21952b02ef664641af6588ef6bd727bf8
+Author: Adam Jackson <ajax@redhat.com>
+Date: Mon Jun 29 11:16:16 2009 -0400
+
+ EDID: Fix timing class names to match the spec
+ (cherry picked from commit 5c1afac5eea1d8327c74342d12d082b75f0cebde)
+
commit dbac41b624e4aa86a6a184b7ebb52bfdd367bbf0
Author: Adam Jackson <ajax@redhat.com>
Date: Fri Jun 19 12:42:07 2009 -0400