summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Brulebois <kibi@debian.org>2011-05-30 11:37:22 +0200
committerCyril Brulebois <kibi@debian.org>2011-05-30 11:37:22 +0200
commit4ee10d0849a2642ba1ef342a843a7d574d1ee30d (patch)
tree99b988f08f5ccdbf146449e35d386605950a2801
parent4c8fbd4a01ee7146ed2451a3a0d248a3b802e1d3 (diff)
On GNU/kFreeBSD, enable HAL support for the main build, but disable it for the udeb build, thanks to Robert Millan (Closes: #596586).
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules6
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d1da2d084..f4da03e3b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ xorg-server (2:1.10.2-1) UNRELEASED; urgency=low
* New upstream release.
* Add 20-workaround-36986.diff to avoid test failures on *i386.
+ * On GNU/kFreeBSD, enable HAL support for the main build, but disable it
+ for the udeb build, thanks to Robert Millan (Closes: #596586).
-- Cyril Brulebois <kibi@debian.org> Mon, 30 May 2011 11:22:21 +0200
diff --git a/debian/rules b/debian/rules
index 87880af81..7d1c012b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -69,7 +69,9 @@ config_backend = --disable-config-dbus
ifeq ($(DEB_HOST_ARCH_OS), linux)
config_backend += --enable-config-udev --disable-config-hal
else ifeq ($(DEB_HOST_ARCH_OS), kfreebsd)
- config_backend += --disable-config-udev --enable-config-hal
+ config_backend += --disable-config-udev
+ config_backend_main += --enable-config-hal
+ config_backend_udeb += --disable-config-hal
else # hurd
config_backend += --disable-config-udev --disable-config-hal
endif
@@ -146,6 +148,7 @@ confflags_main = \
$(build_xfbdev) \
--with-sha1=libgcrypt \
--enable-xcsecurity \
+ $(config_backend_main) \
$(void)
confflags_udeb = \
@@ -176,6 +179,7 @@ confflags_udeb = \
--disable-xephyr \
--disable-xfbdev \
--with-sha1=nettle \
+ $(config_backend_udeb) \
$(void)
$(STAMP_DIR)/autoreconf: $(STAMP_DIR)/stampdir $(QUILT_STAMPFN)