summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 7fa57cd..1238f5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,12 +3,12 @@ CAIRO_PARSE_VERSION
AC_INIT([cairo],
[cairo_version_major.cairo_version_minor.cairo_version_micro],
[http://bugs.freedesktop.org/enter_bug.cgi?product=cairo])
+AC_CONFIG_AUX_DIR(build)
+AC_CONFIG_MACRO_DIR(build)
AC_GNU_SOURCE
AC_USE_SYSTEM_EXTENSIONS
AC_CONFIG_SRCDIR(src/cairo.h)
AC_CONFIG_HEADERS(config.h)
-AC_CONFIG_AUX_DIR(build)
-AC_CONFIG_MACRO_DIR(build)
AM_INIT_AUTOMAKE([1.9.6 gnu -Wall no-define])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_LIBTOOL_WIN32_DLL dnl Must be called before AC_PROG_LIBTOOL
@@ -99,7 +99,7 @@ CAIRO_ENABLE_SURFACE_BACKEND(xcb, XCB, no, [
])
CAIRO_ENABLE_FUNCTIONS(xlib_xcb, Xlib/XCB, no, [
- if test "x$use_xcb" == "xyes" -a "x$use_xlib" == "xyes"; then
+ if test "x$use_xcb" = "xyes" -a "x$use_xlib" = "xyes"; then
xlib_xcb_REQUIRES="x11-xcb"
PKG_CHECK_MODULES(xlib_xcb, $xlib_xcb_REQUIRES, ,
[use_xlib_xcb="no (requires $xlib_xcb_REQUIRES http://xcb.freedesktop.org)"])
@@ -110,13 +110,13 @@ CAIRO_ENABLE_FUNCTIONS(xlib_xcb, Xlib/XCB, no, [
AM_CONDITIONAL(BUILD_XLIB_XCB, test "x$use_xlib_xcb" = "xyes")
CAIRO_ENABLE_FUNCTIONS(xcb_shm, XCB/SHM, auto, [
- if test "x$use_xcb" == "xyes"; then
+ if test "x$use_xcb" = "xyes"; then
xcb_shm_REQUIRES="xcb-shm"
PKG_CHECK_MODULES(xcb_shm, $xcb_shm_REQUIRES, ,
[AC_MSG_RESULT(no)
use_xcb_shm="no (requires $xcb_shm http://xcb.freedesktop.org)"])
else
- use_xcb_shm="no (requires both --enable-xcb)"
+ use_xcb_shm="no (requires --enable-xcb)"
fi
])
AM_CONDITIONAL(BUILD_XCB_SHM, test "x$use_xcb_shm" = "xyes")
@@ -232,7 +232,7 @@ CAIRO_ENABLE_SURFACE_BACKEND(drm, DRM, no, [
])
CAIRO_ENABLE_FUNCTIONS(drm_xr, DRM Xr (DDX), no, [
- if test "x$use_drm" == "xyes"; then
+ if test "x$use_drm" = "xyes"; then
drm_xr_REQUIRES="xorg-server >= 1.6 xproto xextproto >= 7.0.99.1 renderproto x11"
PKG_CHECK_MODULES(drm_xr, $drm_xr_REQUIRES, ,
[AC_MSG_RESULT(no)
@@ -262,7 +262,7 @@ CAIRO_ENABLE_SURFACE_BACKEND(gallium, Gallium3D, no, [
])
CAIRO_ENABLE_FUNCTIONS(xcb_drm, XCB/DRM, no, [
- if test "x$use_xcb" == "xyes" -a "x$use_drm" == "xyes"; then
+ if test "x$use_xcb" = "xyes" -a "x$use_drm" = "xyes"; then
xcb_drm_REQUIRES="xcb-dri2"
PKG_CHECK_MODULES(xcb_drm, $xcb_drm_REQUIRES, ,
[AC_MSG_RESULT(no)
@@ -708,7 +708,7 @@ dnl The tracing utility requires LD_PRELOAD, so only build it for systems
dnl that are known to work.
case $host in
-*-linux*|*-*bsd*|*-solaris*|*-*-darwin*)
+*-linux*|*-*bsd*|*-solaris*|*-*-darwin*|*-dragonfly*)
have_ld_preload="yes"
;;
*)