summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 1 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 1238f5e..f92e84a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -298,7 +298,6 @@ CAIRO_ENABLE_FUNCTIONS(png, PNG, yes, [
])
dnl ===========================================================================
-use_glew="no (not required by any backend)"
CAIRO_ENABLE_SURFACE_BACKEND(gl, OpenGL, no, [
gl_REQUIRES="gl"
PKG_CHECK_MODULES(gl, $gl_REQUIRES,, [
@@ -309,30 +308,10 @@ CAIRO_ENABLE_SURFACE_BACKEND(gl, OpenGL, no, [
gl_NONPKGCONFIG_LIBS="-lGL"
fi])
- # Disable system GLEW on UNIX since it assumes X and crashes with EGL
- have_glew="no"
- case "$host" in
- *-linux*|*-*bsd*|*-solaris*)
- ;;
- *)
- AC_CHECK_HEADER(GL/glew.h,
- [AC_CHECK_LIB(GLEW, glewInit, [have_glew="GLEW"],
- [AC_CHECK_LIB(glew32, glewInit, [have_glew="glew32"],
- [])])])
- ;;
- esac
- AS_IF([test "x$have_glew" != "xno"],[
- gl_NONPKGCONFIG_LIBS="-l$have_glew $gl_NONPKGCONFIG_LIBS"
- use_glew="yes (system library)"
- ], [
- use_glew="yes (private copy)"
- CAIRO_CFLAGS="$CAIRO_CFLAGS -I\$(top_srcdir)/src/glew"
- ])
need_glx_functions=yes
need_wgl_functions=yes
need_egl_functions=yes
])
-AM_CONDITIONAL(BUILD_PRIVATE_GLEW, test "x$use_glew" = "xyes (private copy)")
dnl ===========================================================================
@@ -614,7 +593,7 @@ CAIRO_ENABLE(test_surfaces, test surfaces, no)
dnl ===========================================================================
CAIRO_ENABLE_SURFACE_BACKEND(image, image, always, [
- pixman_REQUIRES="pixman-1 >= 0.18.4"
+ pixman_REQUIRES="pixman-1 >= 0.20.2"
PKG_CHECK_MODULES(pixman, $pixman_REQUIRES, , [AC_MSG_RESULT(no)
use_image="no (requires $pixman_REQUIRES http://cairographics.org/releases/)"])
image_REQUIRES=$pixman_REQUIRES