summaryrefslogtreecommitdiff
path: root/lg3dproto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lg3dproto/Makefile.am')
-rw-r--r--lg3dproto/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/lg3dproto/Makefile.am b/lg3dproto/Makefile.am
new file mode 100644
index 0000000..55476bc
--- /dev/null
+++ b/lg3dproto/Makefile.am
@@ -0,0 +1,39 @@
+# Copyright (c) 2004, Sun Microsystems, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation.
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# SUN MICROSYSTEMS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+# AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+#
+# Except as contained in this notice, the name of Sun Microsystems shall not be
+# used in advertising or otherwise to promote the sale, use or other dealings
+# in this Software without prior written authorization from Sun Microsystems.
+
+lg3ddir = $(includedir)/X11/extensions
+lg3d_HEADERS = lgewire.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = lg3dproto.pc
+
+EXTRA_DIST = autogen.sh lg3dproto.pc.in
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog