summaryrefslogtreecommitdiff
path: root/hw/kdrive/ephyr/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2008-09-28 12:18:16 +0200
committerMatthieu Herrb <matthieu@deville.herrb.net>2008-11-21 18:21:18 +0100
commit6a1b2fed7e465a9c652e8ee250b8eab440945862 (patch)
tree03c8fd7bb308114c1253126311ebd3de3610b572 /hw/kdrive/ephyr/Makefile.am
parent10d472bf9d61bef32d0a383b2e3783e7a1d7621f (diff)
Add a man page for Xephyr, with information from the README file.
Diffstat (limited to 'hw/kdrive/ephyr/Makefile.am')
-rw-r--r--hw/kdrive/ephyr/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/hw/kdrive/ephyr/Makefile.am b/hw/kdrive/ephyr/Makefile.am
index bf1f47567..9380e4d0a 100644
--- a/hw/kdrive/ephyr/Makefile.am
+++ b/hw/kdrive/ephyr/Makefile.am
@@ -83,6 +83,20 @@ Xephyr_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
relink:
rm -f $(bin_PROGRAMS) && make $(bin_PROGRAMS)
+MAN_SRCS = Xephyr.man.pre
+
+appmandir = $(APP_MAN_DIR)
+appman_DATA = Xephyr.$(APP_MAN_SUFFIX)
+
+Xephyr.$(APP_MAN_SUFFIX): Xephyr.man
+ -rm -f Xephyr.$(APP_MAN_SUFFIX)
+ $(LN_S) Xephyr.man Xephyr.$(APP_MAN_SUFFIX)
+
+include $(top_srcdir)/cpprules.in
+
+CLEANFILES = $(appman_DATA) Xephyr.man
+
EXTRA_DIST = \
$(HOSTVIDEO_SRCS) \
- $(HOSTDRI_SRCS)
+ $(HOSTDRI_SRCS) \
+ $(MAN_SRCS)