summaryrefslogtreecommitdiff
path: root/hw/dmx/Makefile.am
diff options
context:
space:
mode:
authorBrian <brian@yutani.localnet.net>2007-04-03 09:27:57 -0600
committerBrian <brian@yutani.localnet.net>2007-04-03 09:28:21 -0600
commita240c039c47c0be22ea5e100692307b26d938747 (patch)
tree3ccf208e7b1769d105a494f1331978953dcf1cb5 /hw/dmx/Makefile.am
parent1cc8db72816cd079f30255046e10043c350bf683 (diff)
Split the xserver/fb/fbcmap.c file into two files.
Now, fbcmap_mi.c contains the fb functions which just wrap mi functions. Previously, these were in fbcmap.c and compiled when XFree86Server was defined. Now, clients of fbcmap should either use fbcmap.c or fbcmap_mi.c and not worry about setting the XFree86Server symbol.
Diffstat (limited to 'hw/dmx/Makefile.am')
-rw-r--r--hw/dmx/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/hw/dmx/Makefile.am b/hw/dmx/Makefile.am
index 41dc5d210..002ea112a 100644
--- a/hw/dmx/Makefile.am
+++ b/hw/dmx/Makefile.am
@@ -16,9 +16,6 @@ GLX_INCS = -I$(top_srcdir)/hw/xfree86/dixmods/extmod \
GLX_DEFS = @GL_CFLAGS@
endif
-# It's essential that fbcmap.c be compiled with this flag for DMX to work!!
-DMX_CFLAGS = -DXFree86Server=1
-
if BUILDDOCS
SUBDIRS += doc
endif
@@ -76,7 +73,7 @@ Xdmx_SOURCES = dmx.c \
dmxwindow.c \
dmxwindow.h \
$(top_srcdir)/mi/miinitext.c \
- $(top_srcdir)/fb/fbcmap.c \
+ $(top_srcdir)/fb/fbcmap_mi.c \
$(GLX_SRCS)