summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2008-05-19 05:15:30 +0200
committerMatthieu Herrb <matthieu@deville.herrb.net>2008-11-21 18:07:03 +0100
commit10d472bf9d61bef32d0a383b2e3783e7a1d7621f (patch)
treeef95cf4bc872183347136074625f4b32d23c2f93 /configure.ac
parentf4e725f248870a2de10449cc8f53de32e7840d45 (diff)
Support for BSD apm
XXX check amd64 pci init
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f5bbd06b..2cdce2fdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -272,6 +272,15 @@ if test -c /dev/xf86 ; then
AC_DEFINE(HAS_APERTURE_DRV, 1, [System has /dev/xf86 aperture driver])
fi
+dnl BSD APM support
+AC_CHECK_HEADER([machine/apmvar.h],[
+ AC_CHECK_HEADER([sys/event.h],
+ ac_cv_BSD_KQUEUE_APM=yes,
+ ac_cv_BSD_APM=yes)])
+
+AM_CONDITIONAL(BSD_APM, [test "x$ac_cv_BSD_APM" = xyes])
+AM_CONDITIONAL(BSD_KQUEUE_APM, [test "x$ac_cv_BSD_KQUEUE_APM" = xyes])
+
dnl glibc backtrace support check (hw/xfree86/common/xf86Events.c)
AC_CHECK_HEADER([execinfo.h],[
AC_CHECK_LIB(c, backtrace, [
@@ -1268,6 +1277,10 @@ if test "x$XORG" = xyes; then
xorg_bus_bsdpci="yes"
;;
openbsd*)
+ if test "x$ac_cv_BSD_APM" = xyes \
+ -o "x$ac_cv_BSD_KQUEUE_APM" = xyes; then
+ XORG_CFLAGS="$XORG_CFLAGS -DXF86PM"
+ fi
XORG_OS="openbsd"
XORG_OS_SUBDIR="bsd"
xorg_bus_bsdpci="yes"