summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2010-08-03 22:57:33 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2011-10-05 15:11:58 +0100
commite05649c8da16dda8545a5218e12ef96b4bc30a4c (patch)
treec44bb8eba677d92d6cdfa557392805d2e2b89f2b /configure.ac
parentf8866c908cda170c12ba44451f06c01319e3b430 (diff)
Cygwin/X: Linkage bodge for swrast, part 1
Remove glapi.c and glthread.c, which contain GL dispatcher symbols which are defined in libGL, and link with libGL for them instead, as dri_swrast.so is linked with libGL on Cygwin to avoid undefined symbols at link time. Also remove glprocs.h which is only referred to by those .c files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2ac1f2ec6..71b6b056a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1008,7 +1008,7 @@ if test "x$GLX" = xyes; then
AC_SUBST(XLIB_CFLAGS)
AC_DEFINE(GLXEXT, 1, [Build GLX extension])
GLX_LIBS='$(top_builddir)/glx/libglx.la'
- GLX_SYS_LIBS="$GLX_SYS_LIBS"
+ GLX_SYS_LIBS="$GLX_SYS_LIBS $GL_LIBS"
else
GLX=no
fi
@@ -1837,8 +1837,9 @@ if test "x$XWIN" = xyes; then
XWIN_SYS_LIBS=-lwinsock2
;;
esac
+
XWIN_LIBS="$FB_LIB $MI_LIB $FIXES_LIB $XEXT_LIB $RANDR_LIB $RENDER_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $OS_LIB"
- XWIN_SYS_LIBS="$XWIN_SYS_LIBS $XWINMODULES_LIBS"
+ XWIN_SYS_LIBS="$XWIN_SYS_LIBS $XWINMODULES_LIBS $GLX_SYS_LIBS"
AC_SUBST(XWIN_LIBS)
AC_SUBST(XWIN_SERVER_NAME)
AC_SUBST(XWIN_SYS_LIBS)