summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2017-10-12 18:40:16 -0700
committerEric Anholt <eric@anholt.net>2017-10-17 13:41:59 -0700
commit4f3e380fa0f192f90e6661ecf5ca1d7e755eed8f (patch)
tree3d45032f82a2e25077ec6298e824d16977cb5373 /meson.build
parent1918c9b1627d5403e2efbffa03441c4b7d61a63e (diff)
meson: Add support for the vc5 driver.
v2: Default vc5 to off, since it requires the simulator currently. Add missing dep on the XML generation from libbroadcom_vc5. Reviewed-by: Dylan Baker <dylan@pnwbakers.com> (v1)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9967df08e0..5c42102e12 100644
--- a/meson.build
+++ b/meson.build
@@ -96,6 +96,7 @@ with_gallium_radeonsi = false
with_gallium_nouveau = false
with_gallium_softpipe = false
with_gallium_vc4 = false
+with_gallium_vc5 = false
_drivers = get_option('gallium-drivers')
if _drivers != ''
_split = _drivers.split(',')
@@ -104,6 +105,7 @@ if _drivers != ''
with_gallium_nouveau = _split.contains('nouveau')
with_gallium_softpipe = _split.contains('swrast')
with_gallium_vc4 = _split.contains('vc4')
+ with_gallium_vc5 = _split.contains('vc5')
with_gallium = true
with_dri = true
endif