summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-07 13:24:57 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-01-18 16:01:15 +0000
commit3b887f122f604943f1f05fb3c255a91e6859564d (patch)
tree31aba08b3b9a788ffef56f561bfb4e0cc92af351 /configure.ac
parentd4066216c672bdb074ef3275482145c519e170c1 (diff)
configure: forbid static EGL/GBM
Both libraries implicitly require shared GLAPI which in itself mandates shared libraries. Stop pretending that one can use it and error out at configure stage. Signed-off-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 20 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 8cdaa6aedf..ec280328b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1974,6 +1974,10 @@ dnl
dnl gbm configuration
dnl
if test "x$enable_gbm" = xyes; then
+ if test "x$enable_static" = xyes; then
+ AC_MSG_ERROR([gbm cannot be build as static library])
+ fi
+
if test "x$enable_dri" = xyes; then
if test "x$enable_shared_glapi" = xno; then
AC_MSG_ERROR([gbm_dri requires --enable-shared-glapi])
@@ -2003,24 +2007,24 @@ if test "x$enable_egl" = xyes; then
AC_CHECK_FUNC(mincore, [DEFINES="$DEFINES -DHAVE_MINCORE"])
- if test "$enable_static" != yes; then
- if test "x$enable_dri" = xyes; then
- HAVE_EGL_DRIVER_DRI2=1
+ if test "x$enable_static" = xyes; then
+ AC_MSG_ERROR([egl cannot be build as static library])
+ fi
+
+ if test "x$enable_dri" = xyes; then
+ HAVE_EGL_DRIVER_DRI2=1
+ if test "x$enable_shared_glapi" = xno; then
+ AC_MSG_ERROR([egl_dri2 requires --enable-shared-glapi])
+ fi
+ if test "x$enable_dri3" = xyes; then
+ HAVE_EGL_DRIVER_DRI3=1
if test "x$enable_shared_glapi" = xno; then
- AC_MSG_ERROR([egl_dri2 requires --enable-shared-glapi])
- fi
- if test "x$enable_dri3" = xyes; then
- HAVE_EGL_DRIVER_DRI3=1
- if test "x$enable_shared_glapi" = xno; then
- AC_MSG_ERROR([egl_dri3 requires --enable-shared-glapi])
- fi
- fi
- else
- # Avoid building an "empty" libEGL. Drop/update this
- # when other backends (haiku?) come along.
- AC_MSG_ERROR([egl requires --enable-dri])
+ AC_MSG_ERROR([egl_dri3 requires --enable-shared-glapi])
fi
-
+ else
+ # Avoid building an "empty" libEGL. Drop/update this
+ # when other backends (haiku?) come along.
+ AC_MSG_ERROR([egl requires --enable-dri])
fi
fi
AM_CONDITIONAL(HAVE_EGL, test "x$enable_egl" = xyes)