summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-12-10 22:34:47 +0100
committerMarcel Holtmann <marcel@holtmann.org>2012-12-10 22:34:47 +0100
commita66050d7f4f3936f7da86e73f833f8e5a91f5ce6 (patch)
tree3395da9c2a6d777829192b6726309c31c1855bad /configure.ac
parentbde025b912950450f6e3595a29154f0afb18aa6b (diff)
build: Do not install libbluetooth by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 01bd249a2..608e6b826 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,10 @@ if (test -n "${path_systemdunit}"); then
fi
AM_CONDITIONAL(SYSTEMD, test -n "${path_systemdunit}")
+AC_ARG_ENABLE(library, AC_HELP_STRING([--enable-library],
+ [install Bluetooth library]), [enable_library=${enableval}])
+AM_CONDITIONAL(LIBRARY, test "${enable_library}" = "yes")
+
AC_ARG_ENABLE(test, AC_HELP_STRING([--enable-test],
[enable test/example scripts]), [enable_test=${enableval}])
AM_CONDITIONAL(TEST, test "${enable_test}" = "yes")