summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@redhat.com>2009-06-04 00:05:06 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-06-04 00:05:06 -0400
commit3c570a815afb282df01f41acad385ff0e3e33899 (patch)
tree919523db31fd549cb4e1f722e529a445dc96c13a /configure.ac
parent7077138fb3c633e8791b2a4139ade07dbc677dd3 (diff)
Add an --enable-timers configure option to enable the TIMER_BEGIN/END macros
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74ae807..5409e1d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,17 @@ fi
AM_CONDITIONAL(USE_GCC_INLINE_ASM, test $have_gcc_inline_asm = yes)
+dnl ==============================================
+dnl Timers
+
+AC_ARG_ENABLE(timers,
+ [AC_HELP_STRING([--enable-timers],
+ [enable TIMER_BEGIN and TIMER_END macros [default=no]])],
+ [enable_timers=$enableval], [enable_timers=no])
+
+AC_DEFINE(PIXMAN_TIMERS, 1, [enable TIMER_BEGIN/TIMER_END macros])
+AC_SUBST(PIXMAN_TIMERS)
+
dnl ===================================
dnl GTK+