summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-11-02 11:56:29 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2009-11-02 12:01:45 +0000
commit837eb577b4707e447fafb0dfca378ecf4ea3fda5 (patch)
treee1cc62cb0e6e8195f2984cf4649570fa5c0be77d /configure.ac
parent942a15ba9e85fa3297ad6e65270928ad3c1c0a42 (diff)
sphinx: Add required pthread libs
Switching to pthread-stubs broke the build for sphinx on unbroken platforms [those that do not unnecessarily link against -lpthreads].
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2680f212..e5582a42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,6 +498,13 @@ if test "x$have_pthread" = xno -a "x$use_pthread" = xyes; then
AC_MSG_ERROR([pthread requested but not found])
fi
+have_real_pthread=no
+real_pthread_REQUIRES="pthread"
+PKG_CHECK_MODULES(real_pthread, $real_pthread_REQUIRES,
+ [have_real_pthread=yes],
+ [AC_CHECK_HEADERS([pthread.h],, [have_real_pthread="no (requires $real_pthread_REQUIRES)"])])
+AM_CONDITIONAL(HAVE_REAL_PTHREAD, test "x$have_real_pthread" = "xyes")
+
dnl ===========================================================================
CAIRO_ENABLE_SURFACE_BACKEND(ps, PostScript, yes, [