summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-08-22 22:20:35 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-08-29 17:07:37 +0100
commit7447915381fc64bd0c66f7110c1dd0b8a10d73f5 (patch)
tree68dd313708484605acf0ae890f41964a7ae30388 /configure.ac
parentfcda9fc2f29c2ee7d0bb45c17a2261badfdf430c (diff)
[script] Conditionalise the build
Allow the interpreter to be disabled if we can not satisfy its dependencies.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b726cd42..fbc15763 100644
--- a/configure.ac
+++ b/configure.ac
@@ -641,6 +641,8 @@ AM_CONDITIONAL(BUILD_TRACE,
test "x$have_ld_preload" = "xyes" \
-a "x$have_libz" = "xyes")
+AM_CONDITIONAL(BUILD_SCRIPT, test "x$have_libz" = "xyes")
+
AC_CHECK_LIB(bfd, bfd_openr,
[AC_CHECK_HEADER(bfd.h, [have_bfd=yes],
[have_bfd=no])], [have_bfd=no])