summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 0 insertions, 34 deletions
diff --git a/configure.ac b/configure.ac
index c09e0d92..57e39ffe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -252,40 +252,6 @@ AC_ARG_ENABLE(aegis,
AM_CONDITIONAL(ENABLE_AEGIS, [test x$aegis_enabled = xyes])
-keyring_enabled="no"
-AC_MSG_CHECKING(whether to build with gnome-keyring support)
-AC_ARG_ENABLE(gnome-keyring,
- [ --enable-gnome-keyring build with gnome-keyring support. default=no],
- [
- AC_MSG_RESULT(${enableval})
- keyring_enabled="${enableval}"
- ],
- [
- AC_MSG_RESULT(no)
- keyring_enabled="no"
- ]
-)
-
-PKG_PROG_PKG_CONFIG()
-
-if test "x$keyring_enabled" = xauto
-then
- PKG_CHECK_EXISTS([gnome-keyring-1], [keyring_enabled=yes],
- [keyring_enabled=no])
-fi
-
-AM_CONDITIONAL(ENABLE_GNOME_KEYRING, [test x$keyring_enabled = xyes])
-
-if test "x$keyring_enabled" = xyes
-then
- PKG_CHECK_MODULES([GNOME_KEYRING], [gnome-keyring-1])
- AC_SUBST([GNOME_KEYRING_LIBS])
- AC_SUBST([GNOME_KEYRING_CFLAGS])
- AC_DEFINE([ENABLE_GNOME_KEYRING], [1], [Define whether gnome-keyring support is enabled])
-else
- AC_DEFINE([ENABLE_GNOME_KEYRING], [0], [Define whether gnome-keyring support is enabled])
-fi
-
dnl libaccounts-glib SSO
libaccounts_sso_enabled="no"
AC_MSG_CHECKING(whether to build with libaccounts-glib SSO suport)