summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2010-05-10 12:17:55 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2010-05-10 16:29:07 +0100
commit8eb1c1345b48d9719fecb92e35f86c260a74c820 (patch)
tree153021ce560abd11ded9ff57b0152ba3dcc74c81 /tests/Makefile.am
parent366e300fb469496f060301df594502498fb8c75e (diff)
fd.o #28043: explicitly link tests/* against dbus-glib
This fixes compilation with LDFLAGS=-Wl,--no-add-needed, with GNU gold (where this is the default), and hopefully with recent Fedora (where this appears to be the default for ld too). When the last round of Debian "fails to build with GNU gold" reports came in, nothing in tests/ used libdbus or dbus-glib. However, the test for gnio-utils needs the dbus-glib specialized type system, even though it doesn't actually connect to D-Bus, so it needs to be linked accordingly. Reviewed-by: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 502167d58..01f66510d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -100,6 +100,7 @@ check-local: check-coding-style
LDADD = \
$(top_builddir)/telepathy-glib/libtelepathy-glib.la \
+ $(DBUS_LIBS) \
$(GLIB_LIBS)
AM_CFLAGS = \