summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Deucher <alexander.deucher@amd.com>2015-08-06 11:19:55 -0400
committerAlex Deucher <alexander.deucher@amd.com>2015-08-06 11:19:55 -0400
commitb93594b1bfc48250e95ad1d7e09d53b7b1a8ffac (patch)
tree04210bb2b16f6f3b8fd17e3e5236123c0c141264 /configure.ac
parent11a390ea660f95639b2fd2e67f6a9d9042acd467 (diff)
fix amdgpu cunit configure test harder
Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index db190ebd9704..f2e11509a051 100644
--- a/configure.ac
+++ b/configure.ac
@@ -359,13 +359,14 @@ if test "x$RADEON" = xyes; then
AC_DEFINE(HAVE_RADEON, 1, [Have radeon support])
fi
+# Detect cunit library
+PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
AM_CONDITIONAL(HAVE_CUNIT, [test "x$have_cunit" != "xno"])
+
AM_CONDITIONAL(HAVE_AMDGPU, [test "x$AMDGPU" = xyes])
if test "x$AMDGPU" = xyes; then
AC_DEFINE(HAVE_AMDGPU, 1, [Have amdgpu support])
- # Detect cunit library
- PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
# If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
# do this because Debian (Ubuntu) lacks pkg-config file for cunit.