summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2022-01-20 11:55:26 +1000
committerMarge Bot <emma+marge@anholt.net>2022-01-20 06:41:17 +0000
commit8733d19f534f5988501c4155101850ab3a26c893 (patch)
tree6c2fcb2e1559ad8d074c0efe430a698673585848 /src/meson.build
parentacc2d08cf908a5d25cf5491f7602901d2c310262 (diff)
meson: start building intel earlier.
as intel perf is a big impact, start building the intel subdir earlier so there is less chance of long stalls at the end waiting for one file to link other things. Reviewed-by: Emma Anholt <emma@anholt.net> Reviewed-by: Matt Turner <mattst88@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/14630>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 7cbbf74af78..eac75a3304b 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -79,6 +79,9 @@ endif
if with_any_vk or with_gallium_zink
subdir('vulkan')
endif
+if with_any_intel
+ subdir('intel')
+endif
if with_gallium_radeonsi or with_amd_vk
subdir('amd')
endif
@@ -97,9 +100,6 @@ endif
if with_gallium_virgl or with_virtio_vk
subdir('virtio')
endif
-if with_any_intel
- subdir('intel')
-endif
if with_microsoft_clc or with_gallium_d3d12 or with_spirv_to_dxil
subdir('microsoft')
endif