summaryrefslogtreecommitdiff
path: root/src/mapi/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
committerDylan Baker <dylan@pnwbakers.com>2019-09-25 23:25:27 +0000
commitfafd20f67dec9f5891838435ecde1dedb77ab742 (patch)
tree48d445d77515eff1b43fb3a89025d84d4e91ea51 /src/mapi/meson.build
parent7e53bebcb5867039265b3c8201191b714f3cc347 (diff)
meson: fix logic for generating .pc files with old glvnd
We want to generate PC files for non-glvnd builds and for builds with old glvnd, but the current logic doesn't do that, it builds them unconditionally, and for GLES it builds the shared libraries, which is also not what we want. This does not generate .pc files for gles1 or gles2. Which it we weren't doing before either, making this not a regression but a return to status-quo.o Closes: https://gitlab.freedesktop.org/mesa/mesa/issues/1838 Fixes: 93df862b6affb6b8507e40601212a58012bfa873 ("meson: re-add incorrect pkg-config files with GLVND for backward compatibility") Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/mapi/meson.build')
-rw-r--r--src/mapi/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mapi/meson.build b/src/mapi/meson.build
index 39c1dba7ce0..2c79a04f1df 100644
--- a/src/mapi/meson.build
+++ b/src/mapi/meson.build
@@ -35,7 +35,7 @@ if with_shared_glapi
else
libglapi = []
endif
-if not with_glvnd or glvnd_missing_pc_files
+if not with_glvnd
if with_gles1
subdir('es1api')
endif