summaryrefslogtreecommitdiff
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDave Airlie <airlied@gmail.com>2021-06-01 13:14:51 +1000
committerDave Airlie <airlied@gmail.com>2021-06-14 06:34:05 +1000
commitf3630548f1da904ec6c63b43ece7e68afdb8867e (patch)
tree05cfc909591aba9d8bf4bdeb9ba32ce8db2c58f4 /src/gallium/meson.build
parent8da92b5c0a358e30be557cae3303a4027b24db1c (diff)
crocus: initial gallium driver for Intel gfx 4-7
This is a gallium driver for the Intel gfx 4-7 GPUs. It was initially cloned from the iris driver by Ilia Mirkin, then I ported over large reams of code from i965 until it worked. Acked-by: Jason Ekstrand <jason@jlekstrand.net> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/11146>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index 3b3bb07f1de..e64d7399ae1 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -129,6 +129,12 @@ if with_gallium_tegra
else
driver_tegra = declare_dependency()
endif
+if with_gallium_crocus
+ subdir('winsys/crocus/drm')
+ subdir('drivers/crocus')
+else
+ driver_crocus = declare_dependency()
+endif
if with_gallium_iris
subdir('winsys/iris/drm')
subdir('drivers/iris')