summaryrefslogtreecommitdiff
path: root/src/egl/meson.build
diff options
context:
space:
mode:
authorRoman Stratiienko <r.stratiienko@gmail.com>2021-04-20 18:37:21 +0300
committerMarge Bot <eric+marge@anholt.net>2021-06-07 16:04:15 +0000
commit016e932cdae168d8db5a603ce17182f00dcee79a (patch)
tree9e043169219affe9dd155f1e8841ef480792010f /src/egl/meson.build
parent45814b58c1da012110bac7317fcf8bb2e94feee7 (diff)
meson: egl: Do not build platform_drm for Android
'platform_android' wasn't designed to coexist with 'platform_drm' within single build, therefore a lot of conflicts appears during compile-time. Signed-off-by: Roman Stratiienko <r.stratiienko@gmail.com> Reviewed-by: Eric Engestrom <eric@engestrom.ch> Acked-by: Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com> Tested-by: Mauro Rossi <issor.oruam@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/10183>
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 599a66706b7..055cfcf75fb 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -105,7 +105,7 @@ if with_dri2
endif
deps_for_egl += [dep_x11_xcb, dep_xcb_dri2, dep_xcb_xfixes]
endif
- if with_gbm
+ if with_gbm and not with_platform_android
files_egl += files('drivers/dri2/platform_drm.c')
link_for_egl += libgbm
incs_for_egl += [inc_gbm, include_directories('../gbm/main')]