summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 28cb28ec..3bbc1956 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,15 @@ IF(DRM_INTEL_FOUND)
ELSE(DRM_INTEL_VERSION VERSION_GREATER 2.4.57)
MESSAGE(STATUS "Disable userptr support")
ENDIF(DRM_INTEL_VERSION VERSION_GREATER 2.4.57)
+ IF(DRM_INTEL_VERSION VERSION_GREATER 2.4.59)
+ MESSAGE(STATUS "Enable EU total query support")
+ SET(DRM_INTEL_EU_TOTAL "enable")
+ MESSAGE(STATUS "Enable subslice total query support")
+ SET(DRM_INTEL_SUBSLICE_TOTAL "enable")
+ ELSE(DRM_INTEL_VERSION VERSION_GREATER 2.4.59)
+ MESSAGE(STATUS "Disable EU total query support")
+ MESSAGE(STATUS "Disable subslice total query support")
+ ENDIF(DRM_INTEL_VERSION VERSION_GREATER 2.4.59)
ELSE(DRM_INTEL_FOUND)
MESSAGE(FATAL_ERROR "Looking for DRM Intel (>= 2.4.52) - not found")
ENDIF(DRM_INTEL_FOUND)