summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 07:39:48 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-07-16 07:39:48 +0000
commit8e600b87643f7f4e19923dd6a0f2eec83303363a (patch)
treefbad9acc7e1df39bb44567bf73b1230f68eb9cfa /configure.ac
parent4f04e26c69747929243f176feaa90f3042481f53 (diff)
Only pass -rdynamic when using gcc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 44b906696..ea74ad3f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -728,6 +728,15 @@ if test "x$GCC" = "xyes"; then
XSERVER_CFLAGS="$GCC_WARNINGS $XSERVER_CFLAGS"
fi
+# The Xorg binary needs to export symbols so that they can be used from modules
+# Some platforms require extra flags to do this. gcc should set these flags
+# when -rdynamic is passed to it, other compilers/linkers may need to be added
+# here.
+if test "x$GCC" = "xyes"; then
+ LD_EXPORT_SYMBOLS_FLAG="-rdynamic"
+fi
+AC_SUBST([LD_EXPORT_SYMBOLS_FLAG])
+
AC_DEFINE_DIR(PROJECTROOT, prefix, [Overall prefix])
AC_SUBST([XORG_CFLAGS])