summaryrefslogtreecommitdiff
path: root/config/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2007-07-08 14:28:58 +0300
committerDaniel Stone <daniel@fooishbar.org>2007-08-01 01:53:31 +0300
commit1cdadc2f43d9069572814510d04b1a560c488fcb (patch)
tree09e403c8ff69abbc00e635c787c83e43fd3a26d7 /config/Makefile.am
parent8bfa41e1bf3f588780d7e9f6f900b1fde0570a7e (diff)
Hotplug: Separate D-Bus into core and hotplug API components
Break up D-Bus into two components: a D-Bus core that can be used by any part of the server (for the moment, just the D-Bus hotplug API, and the forthcoming HAL hotplug API), and the old D-Bus hotplug API.
Diffstat (limited to 'config/Makefile.am')
-rw-r--r--config/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
index 43c9aa330..527034493 100644
--- a/config/Makefile.am
+++ b/config/Makefile.am
@@ -1,10 +1,19 @@
AM_CFLAGS = @DIX_CFLAGS@
+noinst_LIBRARIES = libconfig.a
+libconfig_a_SOURCES = config.c
+
+if HAVE_DBUS
+AM_CFLAGS += @DBUS_CFLAGS@
+libconfig_a_SOURCES += dbus-core.c
+endif
+
+if CONFIG_DBUS_API
dbusconfigdir = $(sysconfdir)/dbus-1/system.d
dbusconfig_DATA = xorg-server.conf
noinst_LIBRARIES = libconfig.a
-
-libconfig_a_SOURCES = config.c
+libconfig_a_SOURCES += dbus.c
+endif
EXTRA_DIST = xorg-server.conf