summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2012-01-30 14:04:04 +0100
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2012-04-06 14:01:19 +0200
commitbfeda130de340c090895d23ea0a5742521ff0078 (patch)
tree4b989a3e5e1472b644f690be28cc519666810d62 /configure.ac
parent1a36156972f14bb8d481abd71cb4210eb226a7ba (diff)
Introduce weston-launch
weston-launch starts weston and provides mechanism for weston to set/drop drm master, open a tty, and read input devices without being root. Execution is allowed for local-active sessions or users in the group weston-launch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffed655..038e619 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,6 +151,22 @@ if test x$enable_clients = xyes; then
[AC_MSG_WARN([Cairo-EGL not found - clients will use cairo image])])
fi
+AC_ARG_ENABLE(weston-launch, [ --enable-weston-launch],, enable_weston_launch=yes)
+AM_CONDITIONAL(BUILD_WESTON_LAUNCH, test x$enable_weston_launch == xyes)
+if test x$enable_weston_launch == xyes; then
+ PKG_CHECK_MODULES(WESTON_LAUNCH, [libdrm])
+ PKG_CHECK_MODULES(SYSTEMD_LOGIN, [libsystemd-login],
+ [have_systemd_login=yes], [have_systemd_login=no])
+ AS_IF([test "x$have_systemd_login" = "xyes"],
+ [AC_DEFINE([HAVE_SYSTEMD_LOGIN], [1], [Have systemd-login])])
+
+ AC_CHECK_LIB([pam], [pam_open_session], [have_pam=yes], [have_pam=no])
+ if test x$have_pam == xno; then
+ AC_ERROR([weston-launch requires pam])
+ fi
+ WESTON_LAUNCH_LIBS="$WESTON_LAUNCH_LIBS -lpam"
+fi
+
AM_CONDITIONAL(HAVE_POPPLER, test "x$have_poppler" = "xyes")
AM_CONDITIONAL(BUILD_FULL_GL_CLIENTS,