summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSiarhei Siamashka <siarhei.siamashka@nokia.com>2011-02-22 19:28:08 +0200
committerSiarhei Siamashka <siarhei.siamashka@nokia.com>2011-02-22 19:43:57 +0200
commit65919ad17fd7b4c6f963690fc78155c7cfe1a51a (patch)
tree27b7b159d788ef4c2aba43ef1c2f6f42e4f4e338 /Makefile.am
parent34a7ac047411d6c1f1708cb8dd4469cd1aa40b31 (diff)
Ensure that tests run as the last step of a build for 'make check'
Previously 'make check' would compile and run tests first, and only then proceed to compiling demos. Which is not very convenient because of the need to scroll back console output to see the tests verdict. Swapping order of SUBDIRS variable entries in Makefile.am resolves this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 062c58a..f479a66 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = pixman test demos
+SUBDIRS = pixman demos test
pkgconfigdir=$(libdir)/pkgconfig
pkgconfig_DATA=pixman-1.pc