summaryrefslogtreecommitdiff
path: root/exa/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2005-08-08 00:38:41 +0000
committerKeith Packard <keithp@keithp.com>2005-08-08 00:38:41 +0000
commit4dfc3357a78a52ef70750608138dfeef0371cbc4 (patch)
treeb810fd3b3033346c3d844fa711dc494a4e689526 /exa/Makefile.am
parent7d2b08aa4786eb4d181c88f7dc6b7eb059cc9dad (diff)
Add autogenerated source files and other various non-CVS material to
.cvsignore files Use XORG_CFLAGS. Ensure that all exa files are in SOURCES remove _XOPEN_SOURCE as it's always in xtrans.pc these days and gcc whines libdamage.la needs libcw.la when COMPOSITE is defined, but that libdamage.la must be after libcomposite.la, so add libcw.la to DAMAGE_LIB instead of EXTENSION_LIBS. Regularize library link order across all X servers
Diffstat (limited to 'exa/Makefile.am')
-rw-r--r--exa/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/exa/Makefile.am b/exa/Makefile.am
index 045033165..7a5e7905b 100644
--- a/exa/Makefile.am
+++ b/exa/Makefile.am
@@ -5,5 +5,13 @@ sdk_HEADERS = exa.h
libexa_la_LDFLAGS = -avoid-version
INCLUDES = $(XORG_INCS)
-DEFS += -DPIXPRIV
-libexa_la_SOURCES = exa.c exaasync.c exaoffscreen.c exapict.c
+
+AM_CFLAGS = $(XORG_CFLAGS)
+
+libexa_la_SOURCES = \
+ exaasync.c \
+ exa.c \
+ exa.h \
+ exaoffscreen.c \
+ exapict.c \
+ exaPriv.h