summaryrefslogtreecommitdiff
path: root/thirdparty/libpng/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'thirdparty/libpng/CMakeLists.txt')
-rw-r--r--thirdparty/libpng/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/thirdparty/libpng/CMakeLists.txt b/thirdparty/libpng/CMakeLists.txt
new file mode 100644
index 0000000..7775f91
--- /dev/null
+++ b/thirdparty/libpng/CMakeLists.txt
@@ -0,0 +1,23 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+add_library (png_bundled STATIC
+ png.c
+ pngerror.c
+ pngget.c
+ pngmem.c
+ pngpread.c
+ pngread.c
+ pngrio.c
+ pngrtran.c
+ pngrutil.c
+ pngset.c
+ pngtrans.c
+ pngwio.c
+ pngwrite.c
+ pngwtran.c
+ pngwutil.c
+)
+
+set_target_properties (png_bundled PROPERTIES
+ COMPILE_FLAGS "${CMAKE_SHARED_LIBRARY_C_FLAGS}"
+)