summaryrefslogtreecommitdiff
path: root/thirdparty/libpng/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2011-06-30 13:28:42 +0100
committerJosé Fonseca <jfonseca@vmware.com>2011-06-30 13:28:42 +0100
commita3c7e4179469c6194890ad11c64f51ced48f0177 (patch)
tree86ff81003299b8af7c5f5910aeff1052ee2eb346 /thirdparty/libpng/CMakeLists.txt
parentd5b95b3be2e2232624ec84f6774042a389a88213 (diff)
Put all thirdparty code into a separate subdirectory.
Diffstat (limited to 'thirdparty/libpng/CMakeLists.txt')
-rw-r--r--thirdparty/libpng/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/thirdparty/libpng/CMakeLists.txt b/thirdparty/libpng/CMakeLists.txt
new file mode 100644
index 0000000..7775f91
--- /dev/null
+++ b/thirdparty/libpng/CMakeLists.txt
@@ -0,0 +1,23 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+
+add_library (png_bundled STATIC
+ png.c
+ pngerror.c
+ pngget.c
+ pngmem.c
+ pngpread.c
+ pngread.c
+ pngrio.c
+ pngrtran.c
+ pngrutil.c
+ pngset.c
+ pngtrans.c
+ pngwio.c
+ pngwrite.c
+ pngwtran.c
+ pngwutil.c
+)
+
+set_target_properties (png_bundled PROPERTIES
+ COMPILE_FLAGS "${CMAKE_SHARED_LIBRARY_C_FLAGS}"
+)