summaryrefslogtreecommitdiff
path: root/hw/xfree86/os-support/bus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/os-support/bus/Makefile.am')
-rw-r--r--hw/xfree86/os-support/bus/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/hw/xfree86/os-support/bus/Makefile.am b/hw/xfree86/os-support/bus/Makefile.am
new file mode 100644
index 000000000..4e9d7861b
--- /dev/null
+++ b/hw/xfree86/os-support/bus/Makefile.am
@@ -0,0 +1,19 @@
+noinst_LIBRARIES = libbus.a
+sdk_HEADERS = xf86Pci.h
+
+PCI_SOURCES = @XORG_OS@Pci.c ix86Pci.c
+
+libbus_a_SOURCES = Pci.c $(PCI_SOURCES)
+
+if XORG_BUS_SBUS
+ libbus_a_SOURCES += Sbus.c
+endif
+
+INCLUDES = $(XORG_INCS)
+
+EXTRA_DIST = \
+ 460gxPCI.h \
+ Pci.h \
+ altixPCI.h \
+ e8870PCI.h \
+ zx1PCI.h