summaryrefslogtreecommitdiff
path: root/fc-match/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fc-match/Makefile.am')
-rw-r--r--fc-match/Makefile.am27
1 files changed, 25 insertions, 2 deletions
diff --git a/fc-match/Makefile.am b/fc-match/Makefile.am
index 71dc164..00d3330 100644
--- a/fc-match/Makefile.am
+++ b/fc-match/Makefile.am
@@ -23,10 +23,33 @@
bin_PROGRAMS=fc-match
-man_MANS=fc-match.1
+DOC2MAN = docbook2man
+
+FC_MATCH_SRC=${top_srcdir}/fc-match
+
+SGML = ${FC_MATCH_SRC}/fc-match.sgml
INCLUDES=-I${top_srcdir} $(FREETYPE_CFLAGS) $(WARN_CFLAGS)
-EXTRA_DIST=$(man_MANS)
+EXTRA_DIST=fc-match.sgml
fc_match_LDADD = ${top_builddir}/src/libfontconfig.la
+
+if USEDOCBOOK
+
+man_MANS=fc-match.1
+
+${man_MANS}: ${SGML}
+ $(RM) $@
+ $(DOC2MAN) ${SGML}
+ $(RM) manpage.refs manpage.links
+
+all-local: $(man_MANS)
+
+clean-local:
+ $(RM) $(man_MANS)
+
+else
+all-local:
+clean-local:
+endif