summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2003-03-01 03:06:37 +0000
committerKeith Packard <keithp@keithp.com>2003-03-01 03:06:37 +0000
commit0da305f7f85ae0dddc411df53ef077709558d369 (patch)
treefcf9b99617f0a5337fcff97df91330355407d01c /configure.in
parent584ac89a017d30fb337de3d4c038ae2a5b51b3d1 (diff)
Switch to docbook and split documentation into pieces
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index bfb8bcb..ed03f1a 100644
--- a/configure.in
+++ b/configure.in
@@ -289,6 +289,20 @@ AC_SUBST(CONFDIR)
ORTH_FILES=`cd fc-lang && echo *.orth`
AC_SUBST(ORTH_FILES)
+#
+# Figure out where to install documentation
+#
+
+AC_ARG_WITH(docdir, [ --with-docdir=DIR Use DIR to store documentation files (default ${datadir}/doc/fontconfig)], confdir="$withval")
+
+if test "x$with_docdir" = "x" ; then
+ DOCDIR='${datadir}/doc/fontconfig'
+else
+ DOCDIR=$with_docdir
+fi
+
+AC_SUBST(DOCDIR)
+
AC_OUTPUT([
Makefile
fontconfig/Makefile
@@ -296,6 +310,7 @@ fc-lang/Makefile
src/Makefile
fc-cache/Makefile
fc-list/Makefile
+doc/Makefile
fontconfig.spec
fontconfig.pc
fonts.conf