summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Martin <consume.noise@gmail.com>2013-02-28 19:39:06 +0100
committerMatt Turner <mattst88@gmail.com>2013-03-04 10:11:01 -0800
commit998d975e38db7478781130b42a4fb68d6b181055 (patch)
tree7213e34e7ee388e135732083d6ab4c71cfb976f1 /configure.ac
parentb1390c7992c457f230cb5a7a64803b194de316e0 (diff)
Fix build of swrast only without libdrm
Reviewed-by: Matt Turner <mattst88@gmail.com> Signed-off-by: Daniel Martin <consume.noise@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5f95a78d26..785259554b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1095,7 +1095,7 @@ if test "x$enable_dri" = xyes; then
fi
# if we are building any dri driver other than swrast or using the dri state tracker ...
- if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast || test "x$enable_dri" = xyes; then
+ if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast -a "x$enable_dri" = xyes; then
# ... libdrm is required
if test "x$have_libdrm" != xyes; then
AC_MSG_ERROR([DRI drivers requires libdrm >= $LIBDRM_REQUIRED])