summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac83244..1758f42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -165,6 +165,15 @@ AC_CHECK_DECLS([OMX_VIDEO_CodingVP8],
], [[#include <OMX_Video.h>]])
AM_CONDITIONAL(HAVE_VP8, test "x$HAVE_VP8" = "xyes")
+AC_CHECK_DECLS([OMX_VIDEO_CodingTheora],
+ [
+ AC_DEFINE(HAVE_THEORA, 1, [OpenMAX IL has Theora support])
+ HAVE_THEORA=yes
+ ], [
+ HAVE_THEORA=no
+ ], [[#include <OMX_Video.h>]])
+AM_CONDITIONAL(HAVE_THEORA, test "x$HAVE_THEORA" = "xyes")
+
dnl Check for -Bsymbolic-functions linker flag used to avoid
dnl intra-library PLT jumps, if available.
AC_ARG_ENABLE(Bsymbolic,