summaryrefslogtreecommitdiff
path: root/glib/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-04-09 19:59:14 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-04-11 05:30:29 -0700
commit16966c230e93086d4f293d30438ab67f948f6a4e (patch)
treec9b72d7ac0868fff2c453d606aaf3f7c77847541 /glib/configure.ac
parente213234744e233d3e7b1c69450308138d702242d (diff)
glib: Don't build GRegex or distribute pcre
In order to avoid the bundled pcre in our bundled glib, just remove and disable the GRegex API. We don't currently need this in pkg-config anyway.
Diffstat (limited to 'glib/configure.ac')
-rw-r--r--glib/configure.ac60
1 files changed, 0 insertions, 60 deletions
diff --git a/glib/configure.ac b/glib/configure.ac
index 8970f2c..41780cd 100644
--- a/glib/configure.ac
+++ b/glib/configure.ac
@@ -2431,64 +2431,6 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
[broken_poll="no (cross compiling)"])
AC_MSG_RESULT($broken_poll)
-dnl *********************
-dnl *** GRegex checks ***
-dnl *********************
-
-PCRE_REQUIRED_VERSION=8.11
-
-# Check if we should use the internal or the system-supplied pcre
-AC_ARG_WITH(pcre,
- [AC_HELP_STRING([--with-pcre=@<:@internal/system@:>@],
- [whether to use system PCRE [default=internal]])])
-
-AM_CONDITIONAL(USE_SYSTEM_PCRE, [test "x$with_pcre" = xsystem])
-
-if test "x$with_pcre" = xsystem; then
- PKG_CHECK_MODULES(PCRE,
- libpcre >= $PCRE_REQUIRED_VERSION)
- AC_CACHE_CHECK([for Unicode support in PCRE],glib_cv_pcre_has_unicode,[
- glib_save_CFLAGS="$CFLAGS"
- glib_save_LIBS="$LIBS"
- CFLAGS="$CFLAGS $PCRE_CFLAGS" LIBS="$PCRE_LIBS"
- AC_TRY_RUN([#include <pcre.h>
- int main () {
- int support;
- pcre_config (PCRE_CONFIG_UTF8, &support);
- if (!support)
- return 1;
- pcre_config (PCRE_CONFIG_UNICODE_PROPERTIES, &support);
- if (!support)
- return 1;
- return 0;
- }],
- glib_cv_pcre_has_unicode=yes,
- glib_cv_pcre_has_unicode=no,
- glib_cv_pcre_has_unicode=yes)
- CFLAGS="$glib_save_CFLAGS"
- LIBS="$glib_save_LIBS"
- ])
- if test "$glib_cv_pcre_has_unicode" = "no"; then
- AC_MSG_ERROR([*** The system-supplied PCRE does not support Unicode properties or UTF-8.])
- fi
- AC_SUBST(PCRE_CFLAGS)
- AC_SUBST(PCRE_LIBS)
- AC_DEFINE(USE_SYSTEM_PCRE, [], [using the system-supplied PCRE library])
- PCRE_REQUIRES=libpcre
- AC_SUBST(PCRE_REQUIRES)
-else
- # If using gcc 4 pass -Wno-pointer-sign when compiling the internal PCRE
- if test x"$GCC" = xyes; then
- AC_MSG_CHECKING([whether compiler understands -Wno-pointer-sign])
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -Wno-pointer-sign"
- AC_TRY_COMPILE([],[],[PCRE_WARN_CFLAGS="$PCRE_WARN_CFLAGS -Wno-pointer-sign"
- AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)])
- CFLAGS="$save_CFLAGS"
- fi
-fi
-AC_SUBST(PCRE_WARN_CFLAGS)
-
dnl **********************
dnl *** Win32 API libs ***
dnl **********************
@@ -3446,8 +3388,6 @@ Makefile
glib/Makefile
glib/libcharset/Makefile
glib/gnulib/Makefile
-glib/pcre/Makefile
-glib/update-pcre/Makefile
m4macros/Makefile
])