summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-03-03 15:13:33 -0800
committerDan Nicholson <dbn.lists@gmail.com>2012-03-03 15:13:33 -0800
commitfc11b623161ede884306913e79f7278a2d9d5454 (patch)
treee9e28f91c842d93778de2eeeabc1a9908bbfbf91 /test/Makefile.am
parentfb1f9f83b11cf5c5a42396b717259af8a33c1406 (diff)
plugin: Greatly simplify plugin
And it works! Instead of using the EvPreviewer object, just create the documents and widgets straight in the plugin. This removes the toolbar for now and just leaves a scrolled window for the view. We'll get that back later.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index a395d08..8974c61 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,6 @@
-AM_CFLAGS = $(PREVIEWER_CFLAGS) $(E_CFLAGS)
-LDADD = $(top_builddir)/previewer/libevpreviewer.la $(PREVIEWER_LIBS)
+AM_CFLAGS = $(PLUGIN_CFLAGS) $(E_CFLAGS)
+LDADD = $(PLUGIN_LIBS)
-noinst_PROGRAMS = previewer mime
+noinst_PROGRAMS = mime
mime_SOURCES = mime.c $(top_srcdir)/src/evbp-mime.c
-mime_LDADD = $(PREVIEWER_LIBS)