summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2012-08-08 05:37:32 -0700
committerDan Nicholson <dbn.lists@gmail.com>2012-08-08 05:37:32 -0700
commita6d62fdebecbbe4495a3ed43b5ca0253cb14888f (patch)
treeede4732c5670a18695bb0c33b215f1e318f95af5 /test/Makefile.am
parent93018c25fc372ac15fe285cf471d1d2f496fe739 (diff)
test: Convert previewer to socket/plug
This plugs a big hole in the previewer test app where the widget was used differently than in the browser. Now they both get instantiated through GtkSocket/GtkPlug.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7b65dd4..2f5bc40 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,5 @@
-AM_CFLAGS = -I$(top_srcdir)/src $(MOZILLA_CFLAGS) $(EVINCE_CFLAGS) $(E_CFLAGS)
+AM_CFLAGS = -I$(top_srcdir)/src $(MOZILLA_CFLAGS) $(EVINCE_CFLAGS) \
+ $(E_CFLAGS) -DPLUG_PROCESS=\"$(abs_builddir)/previewer-plug$(EXEEXT)\"
LDADD = $(top_builddir)/src/libevbp-viewer.la
-noinst_PROGRAMS = mime previewer
+noinst_PROGRAMS = mime previewer previewer-plug