summaryrefslogtreecommitdiff
path: root/src/gallium/targets/libgl-gdi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/targets/libgl-gdi/meson.build')
-rw-r--r--src/gallium/targets/libgl-gdi/meson.build44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/gallium/targets/libgl-gdi/meson.build b/src/gallium/targets/libgl-gdi/meson.build
new file mode 100644
index 0000000000..63cc40b97b
--- /dev/null
+++ b/src/gallium/targets/libgl-gdi/meson.build
@@ -0,0 +1,44 @@
+# Copyright © 2018 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+if cc.get_id() == 'gcc' and host_machine.cpu_family() == 'x86_64'
+ ogldef = files('../../state_trackers/wgl/opengl32.mingw.def')[0]
+else
+ ogldef = files('../../state_trackers/wgl/opengl32.def')[0]
+endif
+
+libopengl32 = shared_library(
+ 'opengl32',
+ ['libgl_gdi.c'],
+ vs_module_defs : ogldef,
+ include_directories : [
+ inc_common, inc_wgl, inc_gallium_winsys_sw, inc_gallium_drivers,
+ ],
+ link_whole : [libwgl],
+ link_with : [
+ libmesa_util, libgallium, libglsl, libmesa_gallium, libwsgdi,
+ libglapi_static, libglapi
+ ],
+ dependencies : [
+ dep_ws2_32, idep_nir, driver_swrast, driver_swr,
+ ],
+ name_prefix : '', # otherwise mingw will create libopengl32.dll
+ install : true,
+)