summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-11-02 16:51:40 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-10 13:00:01 -0800
commit13752af4edcbebabf20c031a4dc441a5bf7456f4 (patch)
tree7d07c2ea5a94d5a41832d28f03fadf915a21376d /src/meson.build
parentdc0ec581f22307bf80db4f90625c874ccc0f37b6 (diff)
meson: move gl pkgconfig generation out of glx
Because the same generation logic is required by xlib glx and gallium-xlib glx, it makes sense to pull it out. v2: - Ensure that libgl is defined before trying to generate a pkgconfig file with it. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 186cf92f47..53c8269a99 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -66,3 +66,17 @@ if with_egl
subdir('egl')
endif
subdir('gallium')
+
+# This must be after at least mesa, glx, and gallium, since libgl will be
+# defined in one of those subdirs depending on the glx provider.
+if with_glx != 'disabled'
+ pkg.generate(
+ name : 'gl',
+ description : 'Mesa OpenGL Library',
+ version : meson.project_version(),
+ libraries : libgl,
+ libraries_private : gl_priv_libs,
+ requires_private : gl_priv_reqs,
+ variables : ['glx_tls=yes'],
+ )
+endif