summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-10-24 17:14:20 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-11-08 14:40:12 +0000
commitc7b65c330fd6ede0c82d3e2f2907e5a3ae864788 (patch)
treea563f7802c55b05a5ab6efe1528ad0e29e959300 /src/Makefile.am
parentba414dba4f1bf354cc9494fd76e3e28b489f13a1 (diff)
wayland-drm: static inline wayland_drm_buffer_get
The function is effectively a direct function call into libwayland-server.so. Thus GBM no longer depends on the wayland-drm static library, making the build more straight forward. And the resulting binary is a bit smaller. Note: we need to move struct wayland_drm_callbacks further up, otherwise we'll get an error since the type is incomplete. v2: Rebase, beef-up commit message, update meson, move struct wayland_drm_callbacks. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> (v1) Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> # meson bit only Acked-by: Eric Engestrom <eric.engestrom@imgtec.com> # for the rest Reviewed-by: Dylan Baker <dylan@pnwbakers.com> # meson
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 22973b14bc..ea530eca7d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -57,7 +57,7 @@ endif
# include only conditionally ?
SUBDIRS += compiler
-## Optionally required by GBM, EGL
+## Optionally required by EGL
if HAVE_PLATFORM_WAYLAND
SUBDIRS += egl/wayland/wayland-drm
endif