summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <chadversary@chromium.org>2017-07-10 10:43:08 -0700
committerChad Versace <chadversary@chromium.org>2017-09-18 14:26:54 -0700
commit7554fa266a87d84d914683a649ad50a654c19ab0 (patch)
treeb29b3913728d4b375f8451ba86172e9ac3e794ac /src/Makefile.am
parentf07ac34e6f3cb61f99009ab9065e1f6a1bc8a945 (diff)
vulkan/registry: Add VK_ANDROID_native_buffer
The VK_ANDROID_native_buffer extension is missing from the official vk.xml. This patch defines the extension in a separate, minimal XML file: vk_android_native_buffer.xml. I chose to add the extension to a new XML file instead of adding it to the official vk.xml in order to avoid conflicts each time we sync the vk.xml from Khronos. This should be only a temporary solution until Jesse Hall is persuaded to add it to the official vk.xml. Reviewed-by: Tapani Pälli <tapani.palli@intel.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e055cb8e70..7ca3c0a12d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -72,7 +72,9 @@ endif
if HAVE_VULKAN_COMMON
SUBDIRS += vulkan
endif
+
EXTRA_DIST += vulkan/registry/vk.xml
+EXTRA_DIST += vulkan/registry/vk_android_native_buffer.xml
if HAVE_AMD_DRIVERS
SUBDIRS += amd