summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichel Dänzer <michel@tungstengraphics.com>2007-01-09 09:53:45 +0100
committerMichel Dänzer <michel@tungstengraphics.com>2007-01-09 09:53:45 +0100
commit359d20532bdcef6a540a551578d000afbb609c2d (patch)
treee78505e5a2a2a20c50177b556cea1e3f465d30ba /configure.ac
parent88740c4855babedbea420b5e1b35ae105d1f1026 (diff)
Require glproto >= 1.4.8 for GLX.
It builds against 1.4.7 as well, but it hardcodes the GLX_EXT_tfp tokens that were finalized in 1.4.8, so GLX_EXT_tfp breaks if the client side was built against an older glproto. This will hopefully alert people to rebuild other components (in particular Mesa) against the new glproto as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3b97e0478..3f5e5d8c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -679,7 +679,7 @@ fi
if test "x$GLX" = xyes && ! test "x$MESA_SOURCE" = x; then
PKG_CHECK_MODULES([XLIB], [x11])
- PKG_CHECK_MODULES([GL], [glproto >= 1.4.7])
+ PKG_CHECK_MODULES([GL], [glproto >= 1.4.8])
AC_SUBST(XLIB_CFLAGS)
AC_DEFINE(GLXEXT, 1, [Build GLX extension])
GLX_LIBS='$(top_builddir)/GL/glx/libglx.la $(top_builddir)/GL/mesa/libGLcore.la'